Nissan Juke Owners Club banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello everyone,
I am wondering if anyone can help me diagnose what happened with my juke. So today i was commuting back from work doing 70mph and suddenly felt jerks in the steering and noticed the traction control light and engine light (red) appear on dash and i continued to drive slowly till i managed to stop safely. After pulling over I switched the engine on and off a few times and these lights disappeared and i pulled away back on to the motorway and must have driven another 10 miles when suddenly the engine lights this time amber and red both along with traction control light appeared again. I could feel the car go limp and despite changing gears and applying gas i could accelerate. This along with a vibration in the whole car with a peculiar sound as if engine was firing and misfiring ]intermittently which i have never experienced.
Any idea what could have gone wrong and roughly what repair charges i am looking at. I will try and upload a audio file with the engine sound on start.
Many thanks.
 

Attachments

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I took my Juke to a local garage which is approved for nissan service. They ran a diagnostics and i am uploading a pic of the same.
To cut long story short the injector cylinder number 4 -electric component failure was the reason for malfunction. The repeair work was completed in 1.5 days and they replaced it with Reman common rail injector part no:CWDDFIA2C59507596. Unit price £ 246
Labour £50. Plus 20% VAT on parts and labour. Total bill 355.20
 

Attachments

1 - 3 of 3 Posts
Top