Nissan Juke Owners Club banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi can someone help me with this I have 2 lights on bash board and not sure what wrong with my juke
2820
 

·
Registered
Joined
·
1 Posts
Orange. One traction light.should be switch under steering wheel to the right. Vera is proper name I believe. Red could be coolant level
 

·
Registered
Joined
·
26 Posts
Both wrong.
The car with lines under it is the ESP switch. This is stability control. Not traction control. Traction control is where it stops the tyres spinning during acceleration. ESP keeps the car more stable during heavy and awkward cornering, heavy braking cornering etc.

The red light is an engine? Can't see.. it needs a look at ASAP by the dealer
 

·
Registered
Joined
·
10 Posts
Both wrong.
The car with lines under it is the ESP switch. This is stability control. Not traction control. Traction control is where it stops the tyres spinning during acceleration. ESP keeps the car more stable during heavy and awkward cornering, heavy braking cornering etc.

The red light is an engine? Can't see.. it needs a look at ASAP by the dealer
How does the ESP control the car during heavy awkward corning...? does it somehow stiffen up the suspension
 

·
Registered
Nissan Juke tekna 66 1.5dci
Joined
·
5 Posts
hi all i have the orange ESP light on my dash as well as my BSW and LDW are also now orange. Brake fluid is fine - if not a little full (over the max line) everything worked ok until last Friday - the Juke went into Nissan for the child lock recall repair and came out with and these light appeared the same day. the BSW was working fine prior, i didnt know i had LDW until i read the manual etc. although i havent been able to test this out and wondered if it was related to this - so i switched it off from the menu and BSW and ESP light remain on and orange.
At the same time i had the recall done i got new boot parcel shelf clips put in by the service part guy and im wondering if the camera has been knocked as it appears weird on the reverse camera screen....
 

·
Registered
Joined
·
26 Posts
You can turn these systems on and off in the menu. I'd first check you haven't got them off.
If they're still lit up after being selected on you need a dealer consult checker on the car to pull up the reason. Much easier and more accurate. You can guess all day long. Do it right. Have you a picture of the cameras image and I'll tell you if it's right, I used to check these at the factory. (y)
 

·
Registered
Nissan Juke tekna 66 1.5dci
Joined
·
5 Posts
Thanks for this very useful. I have up guessing and took it to my garage who ran it through the machine. It turns out there was a historic code that hadn’t been cleared, so they cleared it and so far so good. The lane departure light and the blind spot symbol have always been on but green. They went orange but are now green again after the code was cleared. If I turn them off then the lane sensor and blind spot indicator doesn’t work. Are you saying I can have this on with out the symbol in the display?
My next challenge is to work out why the stop start system isn’t working lol 😆 I’ve had the car for a week or so and it worked randomly one day when I pull up to some traffic lights, was super excited and then it hasn’t worked since, or atleast I haven’t quite worked out what kicks it in haha!
 
1 - 9 of 9 Posts
Top