Nissan Juke Owners Club banner

1 - 16 of 16 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
Hi all

I thought about posting this in the other phone topic but decided to keep it seperate incase anyone else has/had the same problem.

I've been having some problems connecting my iPhone (3GS with most recent firmware update) via USB for the purposes of listening to music. Sometimes it works ok, but sometimes it just goes silent even though I can see from the screen on the stereo that the track is still playing. I can skip tracks via the car stereo but it's silent. I finally seemed to get it working, then my Mum called me and after the phone call ended, the music went silent again despite the track continuing to play.

I don't know if this is relevant, but it keeps popping up saying "downloading phone data" when it goes silent. I hadn't updated my phone software for about 10 months and thought that this might have been the problem but it's been no better since i updated it over the weekend.

Has this happened to anyone else? I'd be really grateful for any advice!

Rob.

p.s thought i should mention that when the dealer set my phone up with the USB, it worked fine! (until i made a call on the way home, after which it went silent!).
 

·
Registered
Joined
·
575 Posts
Hi Rob,
I've had 3 cars with integrated bluetooth and usb connection - a Kuga, Scirocco and now the Juke. Each one has gone slient after the phone has been used or when the car starts up. It's just something I've come to live with and I just unplug and then replug the phone from the USB.
I know it doesn't help you, but I think thats just how it is
 

·
Registered
Joined
·
175 Posts
Hi Rob,

I think I may have the answer...

If you have Bluetooth (BT)enabledon the phone and paired withthe carthen you need to let theNissan Connect (your radio)connect to theBT beforeplugging the USB in..(look at the audio display to see that the signal and battery meter are there).. if you do this sequence then it should be fine..

It has something to do with the iPhone's connectionpriority. Itprioritises tothe most recent connection it makes, and as the USB is quicker than the BT when you connect the phone and start the car, thecar audio is looking for the USB (as that's what you've told it to do by plugging it in !) but the iPhone has changed thestreamto besent over the BT (frankly I think it gets a bit confused poor thing..)

Unfortunately after a call, it reverts to BT and so is not sending down the USB audio any more, so you need to unplug and then reconnect the USB.

Bit of a pain I know but it's one of the 'characteristics' on the iPhone ... (wait for the HTC crew to gloat on this post as well
..)

Hope this helps !
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #4 ·
Thanks very much for both your replies! I'll definitely try that and see if it works. I'm not too good with technical stuff so I wasn't sure if maybe I was just doing something wrong! Fingers crossed!
 

·
Registered
Joined
·
443 Posts
5523_Juke said:
Hi Rob,
 
I think I may have the answer...
 
It has something to do with the iPhone's connection priority. (frankly I think it gets a bit confused poor thing..)

Bit of a pain I know but it's one of the 'characteristics' on the iPhone ... (wait for the HTC crew to gloat on this post as well
..)
 
Hope this helps !

Any one for a Desier
 

·
Registered
Joined
·
61 Posts
Seem to be having a similar issue:

I'm playing music on my iPhone4, then a call comes in, and I try to answer it, but both music (usb) and the incoming call get disconnected (i.e. it's not possible to answer that call).

Anyone work out how to negotiate this? Is it similar to the above situation where I need to wait until my pairing reestablishes itself before plugging in the phone to USB when getting into the car?

Thanks.
 

·
Registered
Joined
·
61 Posts
...and it's driving me crazy!

I tried to allow BT to connect first, then play iPhone (iPOD) music, but as soon as a call comes in, I cannot answer it, and both the USB and call are lost. Unplugging USB and plugging back in restores the music, and I have to retrieve the "missed calls" from the BT phone system. I can never just answer the incoming call!

Has anyone else worked out how to make them all play nicely together?
 

·
Registered
Joined
·
22 Posts


This is incredibly frustrating. Let's face it, by sheer numbers alone the iPhone is the most popular smartphone available and yet the Juke can't work properly with it.

I have exactly the same issue:

Connect iPhone by Bluetooth - calls work fine
Plug in the iPhone via USB - Juke display shows iPod side of things playing songs etc but no audio heard.

Surely this can be fixed by a firmware update to the Connect system? I've noticed Nissan GB have joined the forum so it's perhaps worth sending them a PM...
 

·
Registered
Joined
·
61 Posts
I found that incoming calls can be reconnected on the iPhone side, but the USB needs to be disconnected/reconnected to reestablish play.

I gave up. I put all my music on an 8GB thumb drive, got a USB port for the CLA, and use bluetooth for phonecalls. The 2nd USB is for charging my phone (without Nissan Connect interfering), the OEM USB port is for my music, and if I want to stream anything over 3G from the phone, I use the aux input port to my headphone jack + the iPOD cable attached to my new USB port. Lots of wires, but they're tucked away and short, plus all functions play nicely with the Juke.

I'm not holding my breath for NISSAN to fix it.

I still haven't managed to stream music over Bluetooth. Perhaps USA headunits differ (although they look identical)?
 

·
Registered
Joined
·
2,752 Posts
Wish I had an answer but all I can say is it must be something in the set up as my wife says her iphone4 works fine.Phone call comes in,music fades,phone call finishes and music starts up again.She never has to pair her phone up,it seems to do this automatically.Maybe because hers was the first phone paired?She only puts her bluetooth on when she gets in the car so as not to drain the battery so it might pair at that point.Before she's left the drive she's pugged it into the usb and away she drives,no probs.
 

·
Registered
Joined
·
22 Posts
Mmmm, wonder if it could be down to iPhone version. I'm running a 3GS, which I think the original poster was too.

JUKEOFYORK - can you just confirm - your wife is listening to her iPhone music through the Juke connected by USB when a call comes in, she takes then ends the call and the iPhone music resumes through the USB?

Darex - are you using a iPhone 3GS or iPhone 4?
 

·
Registered
Joined
·
22 Posts
Oh well, that's that theory gone then. I sent a PM to Nissan GB on these boards and they have advised they will forward the info to their technical team and report back.

Hopefully more info on this will be forthcoming.
 
1 - 16 of 16 Posts
Top