Nissan Juke Owners Club banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi,

Got a problem with a 64 plate Nissan Juke. Our entertainment/connect unit system stopped working a few weeks ago. We bought the car from Arnold Clark in Nov 17 and within 6 months, the connect unit started showing the nissan badge and cycling between that screen and a boot-up screen stating "STATUS Update Failed..... Insert Update Media"

We've took it too RRG in Bury for a diagnostics, (which cost £100!) for them to tell us that the whole unit needs replacing at a cost of £2500.

Obviously, within the first year of owning the car, which itself is only just 3 1/2 years old, we were quite astounded.

HAs anybody else experienced such a problem?

How did you get it sorted?

Arnold Clark have said that this isn't covered under their warranty and the vehicle has conveniently just expired from the manufacturers warranty too. We're avidly checking all our paperwork to confirm either way.

If anyone's got any advice, that'd be massively appreciated.

Thanks,
 

·
Registered
Joined
·
1 Posts
Hi, I had an issue with my 63 plate Juke 1.5 ntec Connect system. It kept cutting out and turning itself off, which was very inconvenient when i was following the sat nav. It would restart if i turned the engine off and on again. Mine was still under warranty, so less than 2 years old. I took it back to the Nissan dealer and they replaced it under warranty. It appears it was not a one off if other people are having problems too.

Got a problem with a 64 plate Nissan Juke. Our entertainment/connect unit system stopped working a few weeks ago. We bought the car from Arnold Clark in Nov 17 and within 6 months, the connect unit started showing the nissan badge and cycling between that screen and a boot-up screen stating "STATUS Update Failed..... Insert Update Media"

We've took it too RRG in Bury for a diagnostics, (which cost £100!) for them to tell us that the whole unit needs replacing at a cost of £2500.

Obviously, within the first year of owning the car, which itself is only just 3 1/2 years old, we were quite astounded.

HAs anybody else experienced such a problem?

How did you get it sorted?

Arnold Clark have said that this isn't covered under their warranty and the vehicle has conveniently just expired from the manufacturers warranty too. We're avidly checking all our paperwork to confirm either way.

If anyone's got any advice, that'd be massively appreciated.

Thanks,[/QUOTE]
 

·
Registered
Joined
·
1 Posts
Hi
We have this problem too and quoted the same prices from Nissan in Chesterfield. Paid £100 to be told it needs sending to Clarion at £500 -£800 or replace at £2500.
Has anyone found a fix yet, local radio specialist says can't fit a standard replacement and wont touch it :-(
 

·
Registered
Joined
·
1 Posts
Bought a Nissan Juke in March last year from Arnold Clarke. Had problems with entertainment/connect system for several months, the sound would go off for a few minutes when the radio was playing. Last week the system completely shutdown, nothing is working. The screen goes black then the Nissan badge appears on the screen or sometimes black and red writing appears on the screen. I have contacted Arnold Clarke who today finally returned my calls only to be told the system is not covered by the warranty but they will contact Nissan for advice tomorrow and get back to me. I did point out that I have seen many post on this forum from people reporting the same problem. The guy said he was not aware of any known problems with the connect system. Any advice. Really can’t afford an expensive repair bill.
 

·
Registered
Joined
·
4 Posts
Nissan have just released a software update to solve this. Your Nissan dealer should do it free of charge, & it takes about an hour.
 
1 - 5 of 5 Posts
Top