Nissan Juke Owners Club banner
1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi
2011 1.5dci
Does anyone know what this engine/alternator should charge at?
I read all sorts about the variable charge system that the car might have..
Currently charging at around 12.8V which for me seems low.
Flat battery a few days ago, replaced with new, but feel the battery wasn’t really at fault..
Any info appreciated !!
 

·
Registered
Joined
·
14 Posts
Hi
2011 1.5dci
Does anyone know what this engine/alternator should charge at?
I read all sorts about the variable charge system that the car might have..
Currently charging at around 12.8V which for me seems low.
Flat battery a few days ago, replaced with new, but feel the battery wasn’t really at fault..
Any info appreciated !!
Hi there.... my 65 plate 1.5dci is charging at 13.48v with the lights on full beam,rear window heater,fog lights ect on .....it sits at 12.37v with the engine off .
At cranking it dips to low 10v then within about 5 seconds of starting it leaps to low 14's for about 20 seconds,then sits around 12.85v
It has a new S/S battery .... still has its days when for some unknown reason its as flat as a witches t...pancake

Ive been trying to trace a P0201,0202,0203,0204 injector fault code and have found out that this can be caused by an aftermarket alternator sending the wrong signal back to the ecm and battery conditioner.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Fixed the issue…

fitted a new alternator…. Not cheap…
Did not fix the problem, still not charging..
So used a jump lead to earth the engine block to the body… 14.6V across the battery..

tried to find the engine earth strap, couldn’t, so fitted a new strap from the block to the body..
Seemed to do the trick
 
1 - 3 of 3 Posts
Top