Nissan Juke Owners Club banner
1 - 12 of 12 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter · #1 ·
At the risk of boring you good folks, collected my new Juke on Thursday (..17 years since I had a brand new car!!) and I'm completely in lurve!! Here's a pic:



People at work and where I live are actually now stopping to talk instead of hurrying off?


Took it for a leisurely spin this morning and indicated mpg in 'ECO' mode absolutely fantastic (..reading over 50mpg) for a 1.6 turbo petrol. I'm sure that'll drop drastically as I get more used to the car and experiment with the other 'driver modes', and stop limiting myself to 3500rpm for the first few hundred miles ?!!


Cheers all,


Dom
 

·
Registered
Joined
·
1,082 Posts
Excellent Model and the BEST Colour
Get it out of ECO and into Sport!!!!!! Then you will have a monster grin on your face
 

·
Registered
Joined
·
116 Posts
Congrat's on ya new juke spangles, Would look better with the CROME pack
it look's very plain. I think A lot more members would agree. All the best ******.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #7 ·
Morning Folks!

Thank you for the kind feedback! I know the car is totally bog-standard for the moment. Will almost certainly start to tweak the appearance (..personalise) once I've had it a while longer (...still in the honeymoon phase at present
)

Took it for another spin early this morning in NORMAL mode ...engine response very different from yesterday's ECO jaunt (a lot livelier), and mpg reduced as a result ...but no big surprise there!!

Fab car and very, very pleased with it. SPORT mode is gonna be a real hoot


Take care all,


Dom
 

·
Registered
Joined
·
233 Posts
Get going in sport....
Looking good and very shiney..
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #10 ·
Seems my original pic (at the start of this thread) disappeared and my "sig file" stopped appearing a couple of days ago without me removing it ?? So now, we'll try again and see if pictures & "sig" have been restored after a bit of tinkering.....



...Fingers crossed






Edited by: spangles
 

·
Registered
Joined
·
221 Posts
spangles said:
Seems my original pic (at the start of this thread) disappeared and my "sig file" stopped appearing a couple of days ago without me removing it ??  So now, we'll try again and see if pictures & "sig" have been restored after a bit of tinkering.....



...Fingers crossed



Very pretty
 
1 - 12 of 12 Posts
Top