Engine Malfunction Indicator Light - sensor fault - Nissan Juke Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 07-25-2016, 02:41 PM Thread Starter
Junior Member
 
Join Date: Jul 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Question Engine Malfunction Indicator Light - sensor fault

Hello folks,

I'm having a recurrent problem with a faulty MIL sensor on my 2014 Juke Acenta 1.5dci.

The engine MIL first came on at around 18,000 miles (just before the first service). Garage found no fault with the engine - just a faulty MIL sensor. Since then the sensor has been replaced twice under warranty.

Each time it has been replaced, the engine light has come back on again after around 100 miles of driving (it is on again now). It's driving perfectly fine, so it appears to be a sensor problem again. I see elsewhere on the forum that Nissan recalled some Jukes in 2011 due to a MIL sensor fault - but that was 3 years before mine was built, so presumably can't be the same problem?!

Before I get on to the dealer again, has anyone here had similar issues? Is there another spate of faulty sensors doing the rounds, or is it possibly some other fault that the dealer garage isn't picking up? I'm getting fed up of spending every other Friday taking the car in for repairs

Thanks.

Podski
Podski is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-01-2016, 03:46 AM
Junior Member
 
Join Date: Aug 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
This happened to me on the fourth day of using my second hand 2013 1.5 DCi Acenta Premium and I had to have it seen at a Nissan dealership. However, when the MIL came on, I went into stall mode, but you say that´your´s is driving perfectly fine. I read about the 2011 recall and contacted Nissan customer services who informed me that there was no recall for 2013 Jukes. I hope this does not happen to you again as it will then point so something amiss. I´ll let you know if I experience the same again.
WilliamT is offline  
post #3 of 3 (permalink) Old 10-31-2016, 07:00 AM
Junior Member
 
Join Date: Oct 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
My Nissan Juke 2012 is giving me the same problem. Bought it used with about 19,000 km on the clock and had it checked with an independent mechanic and the verdict was on my side and I was given the green light to go ahead and make the purchase. So, I did!

After having driven less than 200 km, the engine warning light pops up and I immediately informed the seller and had it checked but no problem was found with the engine. They fixed the warning light and again it popped up two days later, with a bit of rattle and shake, when hitting the accelerator. This time, a thorough check was done and still no problem was found...until now, hopefully it was just a sensor malfunction!

I adore driving this vehicle but it seems to remind me of my pug (with whom, the Juke has resemblance with) and like my pug, can be annoying at times...he pisses everywhere and the Juke pops up with the engine indication light with a bit of a rattle and shake.

So, far, after the second time at the mechanic's, all seem to bode well.
roadhog is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Juke Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto light/ wiper sensor leaking Dazraffan Main Message Centre 0 03-16-2014 12:16 PM
Security indicator light on dashboard cazjuke Technical 1 07-10-2013 06:31 PM
Engine fault light on googlybear Faults and Fixes 2 10-03-2011 09:44 AM
Voluntary Recall on Check Engine Light pedrochin Technical 3 03-24-2011 02:37 PM
Engine Check light ON nissanjukebox Faults and Fixes 25 01-09-2011 11:44 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome