SD card not working - Nissan Juke Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 04-18-2016, 03:33 PM Thread Starter
Junior Member
 
Join Date: Apr 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
SD card not working

Hi, I have a 62 plate Juke from new and love it, apart from the inbuilt satnav. The maps are bad, and have sent me to the wrong place more than once. The directions aren't very clear either. Now my SD card has stopped working. I have been in touch with Nisssan who refuse to replace it as it is 6 weeks out of warranty, it's not a known problem (it's all over the Internet) and I didn't use Nissan for my services!
So, my satnav doesn't work. I can get a new SD card for £100 ish, but I'd much rather have TomTom. I could buy a stand alone unit, but that seems daft when I have an inbuilt one. I've searched the net, but not getting anywhere. Can I have it updated to TomTom? Do I need a new unit? Or am I stuck with Connect? It would be lovely if I could just plug a TomTom SD card in and it all worked, but I'm sure it won't be that easy.
Any help much appreciated
kathb0110 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-11-2016, 11:25 PM
Junior Member
 
Join Date: Jun 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had the same problem but fortunately mine was still in warranty. I took pictures and video of it not working into the dealer but they said one of their technicians had to see the "No SD Card Inserted" message onscreen and take a picture before Nissan would do anything. It was annoying as my videos proved the SD card was in place and the message just popped up. It happened to be on the screen one day when I was close to the dealers so I called in but left my partner in the car with the engine running so the message didn't disappear as it had on an earlier occasion when I'd stopped the engine. Their technician came out and messed about then took a picture of it and said it would be sent to Nissan who would then supply them with a new SD card.

As usual it wasn't that easy and Nissan said the whole connect unit needed replacing and it had to be booked in for 2 days to have the job done. No great hardship to me as I got a courtesy car and 2 days later got my car back. Mine was on a 63 plate and only 11 months old when it happened.

Unfortunately as you've already answered your own question, you can buy a standalone Tom Tom or try a new SD card, Nissan never even tried replacing the SD card I'm my car so beware if you go down the replacement SD card route.

jim
jim56 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Juke Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
1.5dci 2013 turbo has stopped working iMusicscales Diesel Issues 0 02-21-2016 11:10 AM
How Nissan is Working to Improve its Quality Administrator JukeOwnersClub.co.uk News 0 03-20-2015 09:16 AM
Folding mirrors stopped working Dazraffan Main Message Centre 5 08-07-2012 03:06 AM
Remote C/locking not working - changed battery too MJG Technical 0 11-03-2011 11:12 AM
Handsfree WORKING Beranicus In Car Equipment 20 05-27-2011 03:05 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome